# Updating For Beta 13

Beta 13 ships with several new extenders to simplify building and maintaining extensions. We do our best to create backward compatibility changes. We recommend changing to new Extenders as soon as they are available.

TIP

If you need help applying these changes or using new features, please start a discussion on the community forum or Discord chat.

# Breaking Changes

  • Dropped support for PHP 7.1.
  • Classes from the Zend namespace are now removed. Use the Laminas namespace instead. See PR #1963.
  • The Flarum\Util\Str::slug() method has been removed including the class. Use Illuminate\Support\Str::slug() instead.
  • The Flarum\Event\ConfigureMiddleware has been removed. Use the proper replacement.
  • Several events used in Event Listeners have been removed, use their replacement extender instead.
  • The LanguagePack extender only loads keys from extensions that are enabled. The translations loaded are based on the yaml files matching the i18n namespace.
  • All notifications are now sent through the queue; without a queue driver they will run as usual.
  • The implementation of avatar upload changed, we're no longer storing files temporarily on disk.
  • The SES mail driver has been removed.
  • Mail driver backward compatibility from beta 12 has been removed, use the new Mail extender or implement the modified interface.

# Recommendations

  • Beta 14 will ship with a rewrite in the frontend (javascript). If you're building for that release, make sure to follow our progress.

# New Features

# Deprecations