Languages

It’s easy to add a new language to your basic Flarum installation. Just follow the instructions below to download and install the language pack of your choice.

Once you have added a language pack, you can set it as the default language for your forum. And if you ever find you don’t need one of your installed language packs, you can always disable it. If you’re using any third-party extensions, be sure to read this before you start.

Language Pack Installation

To begin, visit the Extensions > Languages tag at the Flarum Community site and find a language pack that you want to install.

Language packs are installed the same way as extensions. The language will appear in the Extensions page of the admin interface and you can enable it there.

That’s all there is to it! You should now be able to use the language selector in your site’s header to switch your forum’s display to the new language.

Setting the Default Language

Once you have installed a language pack and made sure it’s working, you may want to set it as the default language for new users and guests. You can do that on the Basics page of the admin interface.

Disabling a Language Pack

If you decide you don’t need to support a certain language, after all, you can turn it off. Simply locate the language pack in the Extensions page of the admin interface and disable it.

Disabling a language can be useful if you’re running a monolingual site and don’t want the language selector to appear in the site header. The language selector is hidden when only one language is enabled.

Third-Party Extensions

While language packs downloaded from the Flarum Community site will generally include translations for all the extensions that come bundled with Flarum, they will not as a rule cover any third-party extensions you may have installed. It is up to developers to provide and maintain translations for their extensions.

So before you install a third-party extension, you should check to make sure it includes translations for each language pack you have installed. If you find that an extension doesn’t support a language you need, please contact the developer directly and arrange to have the necessary translations added.

Last Updated: 11/26/2018, 8:23:57 PM